Critical Microsoft Internet Explorer Patch Required

All versions of MS Internet Explorer require critical security patch to prevent malicious code

Why

On Thursday, Microsoft announced a critical patch for all versions of Internet Explorer. This vulnerability is especially concerning because the victim need only visit a malicious web page which allows malicious code to run on their computer. Typically these site links are delivered through a phishing email or social engineering.

Microsoft and the security community have received reports of this being actively exploited.

Impact

WPI IT will deploy this patch to all domain machines tonight, Friday December 21 at 9 PM. This update will reboot each computer, so please leave your machine on so it can be patched and rebooted automatically.

IT has verified that our Endpoint Protection is up to date, as well as the internet firewalls. When working from home it is important that you login via the VPN to ensure that WPI data and connections are protected.

Action Needed

  • Leave computers powered on. If you have already left campus and your computer is off, the patch will be applied when you return and power it on.
  • Login via VPN when working from off-campus.
  • Perform Windows Updates to apply the patch to personally-managed devices.

More information can be viewed using the Microsoft link below. The page requires you to Accept Terms of Service to view full information.


Timeline

End: 21 December 2018, 11:59 PM

Posted: 21 December 2018, 9:30 AM

Start: 20 December 2018, 5:00 PM

Status

Completed


Timing

From

Thursday

20 December 2018

5:00 PM

To

Friday

21 December 2018

11:59 PM

Posted

21 December 2018, 9:30 AM